The terminology we use for templates might be a bit confusing. I'd like to propose calling them layouts instead. This would make them more consistent with the naming in other frameworks (like Rails, Laravel, and others). It would also let us refer to any view as a "template" no matter if it's a layout, page, or partial.
Open to other name proposals as well. Really looking to bring clarity.