bind method in the view transformation api conflicts with Ruby's bind. Similarly, binder / bindings conflict with the Binding class. I'd like to explore a different naming convention that will avoid these issues.
What we now call "binding data" is really a mapping of values from a data structure into a view that matches the data structure being bound. Using
map is an option, but it conflicts with
Presenter::ViewCollection which includes
A less technical way to think of this is that we're "presenting data". So, renaming
present might work. There might be other, more suitable, names too.
Binder / Bindings
Bindings describe how data should be inserted into the view. For example, you might use a binding to set the
href attribute on a link or the
src attribute on an image. We also use them for formatting values, such as dates. The latter will be moved into something called a Formatter for v1.0 (described in issue #83). We need a better name for the former.
Thinking about what is actually happening, it's really just describing the attributes that should be set on a particular node based on the data being presented. What should we call this?
Eager to hear your thoughts